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AmbiLogique

Electronic Controllers

Features:-

Function Block Programming e

Add Notes to Diagrams o e fie ca view wngow e

Add Line Drawings to Diagrams ey
Upload Programs to Processor Modules

Verify Programs in Processor Modules =

Monitor Live Signals o

View Processor Statistics e
Configure and Edit K-Factor Constants o

<0

The AmbiL_PLC software is designed to run on a .
Windows® personal computer (desktop or portable) and

communicate with an AmbiLogique system via a standard
RS-232 serial port. It has also been demonstrated to run successfully on Linux systems equipped with CrossOver
or Wine overlays, and on Apple computers equipped with the Parallels overlay.

The software is similar to a CAD package, and provides facilities for:-
*  Opening and saving multi-sheet program diagrams
*  Printing diagram sheetst
*  Adding, moving, modifying or deleting functions
*  Changing numbers of inputs on many functions
* Inverting or un-inverting digital function pins
*  Adding, moving, modifying or deleting wires
*  Adding, moving, modifying or deleting textual notes
*  Adding, moving, modifying or deleting decorative lines
*  Labelling function blocks with meaningful names
»  Labelling wires with meaningful names
*  Optionally displaying or hiding wire names
»  Creating numeric constants and wiring these into the diagram
*  Creating cross-references via which signals can connect between sheets, or between points a long
distance apart on the same sheet
»  Checking wiring on a single sheet for inappropriate connections and signal naming errors
*  Checking and compiling multi-sheet diagrams
» Determination of order of execution of function blocks
* Resolution of circular execution races
»  Generation of listings of function blocks in execution order with signal connections and error notes
»  Generation of listings of constants and signals with connection lists and error notes
»  Establishment of communication with AmbiLogique processor module
*  Uploading compiled diagram into processor module
*  Verifying diagram in processor module against diagram on PC %
*  Monitoring signals in processor module and displaying them on PC.
*  Viewing Processor Statistics
« NEW! Viewing, Editing and Maintaining K-Factor Constants

t If you have facilities for printing to Adobe® .pdf files, you can generate documentation in this format directly from
AmbiL_PLC software.

T Note that diagrams cannot be downloaded from the processor module and displayed on the PC. This prevents
your competitors from downloading your diagrams.

AmbilLogique Ltd
1812 Opunake Road, RD29, Hawera 4679, New Zealand
+64 6 764 6567 ph www.ambilogique.com sales@ambilogique.com
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Specifications AmbilLogique
1. PC Requirements: Electronic Controllers
Intel or AMD based personal computer running 32-
bit or 64-bit Windows® (XP onwards)
10 Mb spare on hard disk
256 kB RAM
1024 x 768 display resolution or better
RS-323 COM port capable of 115,200 baud

2. Supplied Media:
CDor
Download from www.ambilogique.com/downloads

3. License Conditions:
Freeware: the software can be copied and distributed provided that it is maintained in its original format
with all copyright notices, installers and identifiers intact.
Regardless of distribution channel, the copyright remains vested in AmbiLogique Pty Ltd.

4. Diagram Size:
Limited only by the target processor. CPDA-01 will run up to 225 function blocks, CPDA-02 up to 400
blocks.

Functions Available with CPDA-02:-

Terminals

TERMIN Analogue or digital input terminal
TERMOUT Analogue or digital output terminal

Logic Gates

AND AND gate, 2 to 15 inputs

OR OR gate, 2 to 15 inputs

XOR XOR (parity) gate, 2 to 15 inputs

VOTE Voting gate (how many of my inputs are TRUE?) 2 to 15 inputs
BITAND Bitwise AND of integers - 2 to 15 inputs

BITOR Bitwise OR of integers - 2 to 15 inputs

MASKIN Bitwise AND of integer and mask, with shift to bring LSB of mask to bit 0.
MASKOUT Shift integer to align with mask, then AND shifted integer and mask.
BITASS Bit assembler precisely places single bits into a multi-bit integer.

Latches & Memories

LATSR Set/Reset latch - Set is edge-triggered, Reset overrides
LATDET D Latch with edge-triggered clock, Preset and Clear

Timers & Counters
TIMER Countdown timer, 1/16 sec to 1 million seconds (12 days)
CLOCK Continuously repeating countdown, period as above

COUNT Up/down counter, preset and clear, edge-triggered clock.
Counts -16 million to + 16 million
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Functions Available with CPDA-02 (continued) ] =
AmbiLogique

Analogue Functions Electronic Controllers

RAMP Analogue version of up/down counter. Can be

preset, cleared, ramped up or down

SAMPH Sample/Hold. Output follows input or holds its value.

PREVSCAN Returns the value of the input signal on the previous scan, i.e. 1/16 sec ago.

Signal Selection

SELCT Select which input signal is routed to output. 2 to 14 signals can be routed.
HIEST Selects most positive signal. 2 to 15 inputs.

LOEST Selects most negative signal. 2 to 15 inputs.

BIGST Selects signal with greatest magnitude. 2 to 15 inputs.

SMLST Selects signal with smallest magnitude. 2 to 15 inputs.

Comparison

CMPEQ Output TRUE if input signals equal. Output can be inverted.

CMPGT Output TRUE if x >y. Output can be inverted.

CMPLT Output TRUE if x <y. Output can be inverted.

INRANGE Output TRUE if x >= Lo AND x <= Hi. Output can be inverted.

Basic Arithmetic

ADD  Sum of inputs. 2 to 15 inputs.

SUB  x- (sum of all other inputs). 2 to 15 inputs.

MULT  Product of all inputs. 2 to 15 inputs.

DIV x / (product of all other inputs). 2 to 15 inputs.
QUOT Largest integer which does not exceed (x /y).

REM  Remainder after extraction of quotient.

RATIO Fast(x*y)/z.

Trigonometric

SINE  Sine of input angle

COS  Cosine of input angle

TAN Tangent of input angle

ASIN  Angle whose sine is fractional part of input.
ACOS Angle whose cosine is fractional part of input
ATAN  Angle whose tangent is input.

Logarithmic
LOG2 Logarithm of input to base 2.

ALOG2 Antilog of input to base 2.
POW  Raises x to the power y.

Please Note: Some AmbiLogique products or components may carry the “AmbilLogic” trade mark from our former
Australian company.
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Installation and Getting Started A m b iL ogique

The software is supplied as a Windows Installer (.msi) file, Electronic Controllers
either on a CD or as a download from the AmbiLogique
website.

Double-clicking the file will start the installation process. The licence conditions need to be accepted, and the
installation path accepted or modified.

The EXAMPLES folder should be copied to a location on the hard disk to which you have read and write access (for
example, under My Documents).

You will need an RS-232 serial port on the computer on which you are going to run the software. The easiest option
is to purchase a USB-serial adaptor: these are obtainable for a few tens of dollars from most computer shops. It is
wise to purchase a 9-pin plug-to-socket extension cable at the same time.

When the adaptor is installed with its driver software, look in Device Manager (within Control Panel, then System) to
find out what the serial port properties are, particularly the COM number. It is useful to set the Port Properties to

[ 115200 baud, 8 data bits, 1 stop bit, no parity ] even though the AmbiL_PLC software will do this automatically.
Note that plugging the adaptor into a different USB port on the same computer can change the COM number.

Once the software is installed and running, use Project->Folder or the tool, | [ || then navigate to the folder
which contains the project you want to work with. - -
You will be looking to open the "project.alp” project control file — opening this will automatically open and display all
of the control diagram sheets.

Remember, each project is totally contained within its own folder, and does not share its folder with any other
project.

Once the project is loaded, simply run down the Project menu items until everything above "Connect to target” is
checked. Note that every sheet needs to be Wire Checked before the project can be compiled.
If you are working with a project which has been completed, "Compile entire project” will already be checked.

Now plug your serial adaptor into the computer, and the other end into the 9-pin D connector on the top of the
POCO-01 Power/Comms module of the PLC. The PLC needs to have power applied.
Select Project->Connect to target, and enter the COM number for your serial port in the dialog box.
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When you OK this, you should see the message "Connected to CPDA-02 OK" (or whichever processor you are
using).

When you have arrived at this point, select Project->Upload to target, and a warning dialog will open. When you OK
the dialog, the control diagram will be loaded into the PLC and then verified.

As soon as you OK the verification message, the PLC will start running the new control diagram.

You can always verify that the control diagram in a PLC matches the one you are looking at on the computer screen.
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Other than this it is not possible to download the control

- -
diagram from the PLC into the computer, for security and AmblL og’que

intellectual property reasons. Electronic Controllers

Once you have mastered these basic operations, you are
encouraged to browse the Help menu items in the AmbilL_PLC software for a more detailed tutorial and
explanations.

Processor Statistics

This feature under the Project menu shows some of the properties of the PLC Processor to which the program is
connected. CPDA-01's with firmware 3.61 and above carry their serial number in electronic form, and this will show
on the Statistics dialog.

Where the control diagram connects with expansion modules, either on the backplane or via communications
cables, the quality of service is displayed in this dialog.

TERMOUT
Foanz
zig
CMFGT k-0
X
i wh PLC Statistics [
Foa03 3
[PrOCESSOR [ BACKPLANE Mo Responses
TRANSACTIONS 247357
Processor Type
e CPDA-O1
Total Transactions Timeouts
Serial Mo, <ian g
Undefined Total Trans. Errors Sentinel Errors
243867 o
Firmware

3.61
Format Errors

Control Diagram 0
Time Used

IS Chedkword Errors

:

In the case above, the serial number had not been embedded into the CPDA-01. Production units have the serial
number embedded as part of the test and calibration process.

The system being examined here carried a control diagram which called for input from an EXDA-01 Expansion
Module in Slot 1. However no module was fitted, so the No-Response count is almost 100%.

The Control Diagram Time Used is expressed as a percentage of the slot time (62.5 milliseconds for a CPDA-01).
This can become important when the function block count exceeds 200.

Pressing the "Refresh" button updates the Time Used and Backplane Transaction statistics.
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K-Factors Ambil Ogiqu e

The K-factors (or K-Values) feature is a valuable Electronic Controllers
addition to the capabilities of the CPDA-02 and the

Auroa gas turbine controllers based on

AmbilLogique's PLC technology.

K-Factors are constants which you place at fixed locations in a special area of the PLC memory. These
are not available on all PLC processors. K-factors are a significant advance on the normal constants you
incorporate into your PLC control diagrams.

K-Factors are very useful for constants which might need frequent alteration, for example for tuning a PID
loop, or for compensating for production tolerances in a product.

Each K-factor can be imported into the control diagram via a TERMIN block using the sUbslot assigned to
K-Factors. Please refer to the manual for the processor you are using for details of the sUbslot which
addresses the K-Factors. The CPDA-02 for example accesses its K-Factors via sUbslot 6. The Register
value in the TERMIN block corresponds with the line number (starting at 0) of the item in the KF file. We
explain the KF file a few paragraphs below.

The Mask value in your TERMIN is normally 0, so that the output is the analog value you have edited into
that location. However, there is no reason why you cannot have an array of digital values in a K-Factor,
and mask them out in the usual way for digital inputs to your control diagram. This is a nice way of
providing the equivalent of a DIL switch bank for selecting options within a product.

In early processors (e.g. CPDA-01), the only way of introducing constant numeric values into a control
diagram is by assigning a numeric label to an incoming cross-reference. This mechanism is still available,
and is useful for constants which never change. The disadvantage of these constants is that they are
consolidated by the compiler so that only one copy of each value is stored. If you decide to change a
constant, the compiled version of your control diagrm will change, because the reference map into the
constants will change. This in turn means that a change to just one constant causes re-compilation of the
entire control diagram. This then requires that the new control diagram is re-loaded into the PLC. This is
time-consuming and involves halting the PLC for a significant time, so the K-Factors facility was introduced
to address this problem.

If you change a K-Factor, its location will not change. Because of the requirements of the Flash memory in
the PLC, the entire changed block (not necessarily the entire K-Factor table) needs to be updated.
However, this only takes a second or so, and the PLC is only halted for this brief upload period.

In order to ease the control and documentation of K-Factors, the details are stored in a text file
'KFsomething.txt' which you can edit and maintain with any normal text editor like Notepad or Notepad++.
We refer to this as the 'KF file."' 'something' is a file name which you assign, but the full filename must start
with 'KF' and the ".txt' extension must be maintained. In this way, KF files are distinct from any other text
files you might have in your working folders.

You might (for example) have a separate K-Factor file for every product you make which incorporates a
PLC.

Each line of the file contains details of a single K-factor, and has the form:-

aa <t> name_of_factor <t> minval <t> maxval <t> startval

‘aa’ is the address of the factor (0 upwards);

<t>is one or more tabs;

'name_of_factor' is a name which you assign to the factor. Note that this cannot include tabs or spaces, so
it is recommended that you use underscores to separate words;

'minval’ is a low limit for the factor value: this is a reminder and will not constrain the value;

'maxval’ is a high limit for the factor value: this is also only a reminder;

'startval' is the starting or recommended value for the factor.

The 'aa’ address field is there as a help when you are editing the K-Factors. Please note that the K-
Factors are loaded into the PLC in the strict order in which they appear in the KF file. If your address fields
are not consecutive, starting from 0, you will not have the K-Factors loaded where you expect.

When you select the K-Factor Edit facility, a 'File Open' dialog opens, which asks you to identify which ".kfe'
file you wish to load. When you have selected this, a new window opens with the editor showing a table
which is populated with the contents of the ".kfe' file.

ALPLC DS 3 4 Page 6 of 8




AmbiL_PLC Software {
A Much Better Idea : Logical : Unique
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Addr. Factor Name Minval Max val Startval Actual
0 CTG_Closed_% a0 100 a5 45
i CTG_Gnd_Idie_% 25 a0 31 31
Staircase Geng
2 CTG_Fit_Idle_% 15 25 19 19
3 CTG_Full_Pwr_%% a 15 8.5 8.5
4 T.Motor_P._factor 0 200 100 100
5 T.Motor_D_factor 0 200 75 75
5| T.M.Intshift(div_2n) 4 1 7 7
F|[ T.M.Dif WindowforInt o 25 125 128
3 T.M.IntLimit 100 1000 440 440
Load Startvals
ik A Bk Refresh _ Update Quit without
from PLC X = Changed toPLC Updating PLC
Load Values -
Startvals Changed 1)
L

The 'Up' and 'Down’ buttons allow you to scroll through a file which contains more than 9 items. You can
have up to 128 K-Factors in any CPDA-02 project.

There are 4 buttons which control the relationship between what you see on the screen and what is in the
PLC:

* Load StartVals

* Refresh

*  Update Target

*  Quit without Updating

'Load StartVals' takes the starting values you specified in the .kfe file and loads these into the 'Actual’
column of the table. Together with the 'Upload' button, this provides a very quick way of getting these
values into the PLC to get your project going.

'Refresh’ will re-download the K-Factors stored in the PLC into the 'Actual' column of the table;
'Update’ will upload the K-Factors from your 'Actual’ table into the PLC;
'Quit" will close the window without altering the PLC contents.

When the window is first opened, it will 'Refresh’ automatically. You can then edit the K-Factors as
needed. It is essential to hit the 'Update’ button if you want the changes to be uploaded into the PLC,
otherwise the changes will be lost when you 'Quit' the editor.

When you alter any of the 'Actual’ values, the 'Values Changed' checkbox shows 'X' to remind you that the
values displayed no longer match those in the PLC.
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AmbiLogique

Electronic Controllers

WARNING
SAFETY-CRITICAL SYSTEMS

A Safety-Critical system is a system whose failure or malfunction could cause death, significant injury or
loss of property.

AmbiLogique products incorporate electronic hardware and software, both of which carry a remote but
real possibility of failure. AMBILOGIQUE DOES NOT WARRANT, CLAIM OR REPRESENT THAT ITS
PRODUCTS ARE INFALLIBLE.

It is therefore THE RESPONSIBILITY OF THE DESIGNER of any safety-critical system which
incorporates AmbilLogique products to ensure that:-

1. The system is designed so that any failure of an AmbiLogique component will not cause
death, injury or loss of property.

2. The system incorporates independent monitoring means which detect the failure of any
of the electronic control elements.

3. The system has alternative and independent means of control which enable it to be
controlled and shut down in an orderly manner.

4. Any and all other industry-specific safety requirements are fully implemented.

Revision History:

R 0.0 2005-01-17 Initial issue.

R 0.1 2009-01-05 Safety notice added.

R 1.0 2010-01-31 Editorial.

R 2.0 2012-01-25 Open Document format, Name change.

R 2.2 2012-10-05 Installation and Basic Operation Instructions added.

R3.31 2013-04-19 Document revision no. aligned with software revision; Processor Statistics
feature added.
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